Skip to content

3Ware Raid reparieren

Seit einiger Zeit haben wir immer wieder das Problem, das aus einem Raid 1 Verbund eine Platte "degraded" wird. Laut Hersteller (Hitachi) liegt es wohl an den SATA Einstellungen - diese solle man von 3 GB/s auf 1,5 GB/s runterfahren! Bei Hitachi ist dies mit dem sogenannten Feature Tool möglich.

Soweit die Vorgeschichte, um jetzt diese Platte wieder in Betrieb nehmen zu können sind folgende Schritte mit Hilfe des tw_cli Tools von 3Ware durchzuführen:

Zuerst die defekte Platte aus dem Raid entfernen (x entsprechend ersetzen):
tw_cli>maint remove cx px

Anschließend kann die defekte Platte ersetzt werden. Als nächsten Schritt muss man nach der neuen Platte suchen lassen und dann steht dem Rebuild eigentlich nichts mehr im Wege!
tw_cli>maint rescan cx
tw_cli>maint rebuild cx ux px

Super Sache

Am gestrigen Dienstag wurde ein neuer Server (PowerEdge SC1435) geliefert! Er soll einen bereits existierende in die Jahre gekommenen Housing Server ersetzen. Nach dem ersten Versuch Ubuntu zu installieren, legte sich dann langsam die Euphorie. Als anschließend auch noch Debian ausstieg, haben wir kurzerhand bei Dell nachgefragt! Der tolle Raidcontroller, der verbaut wurde, unterstützt nur RedHat, SuSE Linux Enterprise Server und die Windows Family. Alles was irgendwie Geld kostet - Ein Schelm der böses dabei denkt! ;-)

Nachtrag: Edgy Eft läuft! :-)

1 Stunde und 46 Minuten

So lange kann es mitunter dauern, bis ein RAID neu gebaut wurde! Dumm dabei ist nur, das dies bei einen unserer gehosteten Server passiert ist! Soll heißen, ich habe fast 2 Stunden in einen mit 16°C gekühlten Serverraum verbracht! Zum Glück hatte ich mein Handy inkl. MiniGolf dabei! :-P